Раздел вопрос-ответ mysqli: Headers and client library minor version mismatch.

Ошибка при работе с mysqli:

mysqli::real_connect(): Headers and client library minor version mismatch. Headers:50533 Library:50615

[vagrant@debian7-packaged ~]$ php --version
PHP 5.4.24-1~dotdeb.1 (cli) (built: Jan 12 2014 04:33:23) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
[vagrant@debian7-packaged ~]$ mysql --version
mysql  Ver 14.14 Distrib 5.6.15, for Linux (x86_64) using  EditLine wrapper

 

share

1 ответ

Мне помогла установка mysqlnd драйвера:

sudo apt-get install php5-mysqlnd

При проблемах с установкой mysqlnd может потребоваться сделать:

sudo apt-get update
sudo apt-get install php5-mysqlnd --fix-missing

 

Добавить комментарий
    как минимум 5 символов

    icon Вход в систему

    зарегистрироваться